mozyのかきおき

mozyの読書感想文や思考置き場

【解決】IntelliJでFlutterアプリ作成時に、Dart SDK is not configure とエラー

起きたこと

IntelliJを使ってflutterでアプリケーションを作ろうとして、プロジェクトを作成したら、 Dart SDK is not configure とのエラーがでた。

flutter doctor では問題なくインストールされている模様。

解決方法

Open Dart Settingを開いて、 Dart SDK Path に /Users/mozy/flutter/bin/cache/dart-sdk のようにパスを設定して、画面下部を以下のようにEnableにチェックを入れたら解決した。 f:id:mozy_ok:20180828010553p:plain

ついでに、
Preferences -> Language and Framework -> Flutter -> Flutter SDK Path からFlutterのパスを確認すると
/Users/mozy/flutter/ となっていて、Versionは

Flutter 0.7.1-pre.28 • channel master • https://github.com/flutter/flutter.git Framework • revision 546449238a (16 hours ago) • 2018-08-26 19:50:02 -0400 Engine • revision af42b6dc95 Tools • Dart 2.1.0-dev.1.0.flutter-ccb16f7282

だった